Patch do Conky

Ostatnio zaktualizowałem Conky do wersji 1.5.2_pre01107 i ku mojemu przerażeniu znacznie wzrosło jego zużycie pamięci. Co prawda downgrade do 1.5.1 pozwolił pozbyć się tych objawów, ale z ciekawości postanowiłem sprawdzić kto jest winowajcą. Cóż, okazało się, że ktoś zapomniał zwolnić jednej zmiennej w funkcji interface_up. Wyciek pojawia się tylko, jeśli w .conkyrc używamy komendy ${if_up …

Continue reading ‘Patch do Conky’ »